Forums

Posting in these forums is disabled. These forums will be available for archive purposes. Please join the new forums at the links below:

  • yui-support - replaces the `YUI 3.x` and `YUI 3 Gallery` forums.
    We have created the following discussion categories within this group to aid discoverability for these most-used topics:
    • Charts for YUI Charts support.
    • DataTable for YUI DataTable support.
    • Gallery for YUI Gallery support, including support for published Gallery components as well as the Gallery process in general.
    • Tools for support of YUI’s suite of developer tools such as selleck, shifter, grover, yogi, etc.
    • Everything Else for questions that don’t fit one of the categories above, we’ve got you covered here.
  • yui-deprecated - replaces the `YUI 2.x` forum and the forums of other deprecated products (`YUI Doc`, `Builder`, `YUI PHP Loader`, etc.).
  [ 8 posts ]
New Topic | Post Reply | Print view
Previous topic | Next topic

Gedion W

  • Username: Gedion
  • Joined: Sun Nov 20, 2011 3:42 pm
  • Posts: 2
  • Offline
  • Profile
Tags:
  • cache
  • node

npm install yeti returns error and 'not ok' message

Post Posted: Sun Nov 20, 2011 4:02 pm
Hello, I'm trying to set up yeti for the first time. I am also a first time npm user.

I have npm version 1.0.106. I was able to set up npm on my unix and windows NT.

Installing yet is giving me error on both machines. When trying it on unix it stops after the first line.

Can someone please guide me to the right direction?

Thank you,

WARN yeti@0.1.9pre package.json: bugs['web'] should probably be bugs['url']
ERR! error installing yeti@0.1.9pre Error: No compatible version found: connect@'>=1.2.3- <1.3.0-'
ERR! error installing yeti@0.1.9pre Valid install targets:
ERR! error installing yeti@0.1.9pre ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.1.0"
,"0.2.0","0.2.1","0.2.2","0.2.3","0.2.4","0.2.5","
0.2.6","0.2.7","0.3.0","0.4.0","0.5.0","0.5.1",
"0.5.2","0.5.3","0.5.4","0.5.5","0.5.6","0.5.7","0.5.8","0.
5.9","0.5.10","1.0.0","1.0.1","1.7.2","1.7.3","1.8.0"]
ERR! error installing yeti@0.1.9pre at installTargetsError (C:\Program Files\nodejs\node_modules\npm\lib\cache.js:424:10)
ERR! error installing yeti@0.1.9pre at C:\Program Files\nodejs\node_modules\npm\lib\cache.js:406:17
ERR! error installing yeti@0.1.9pre at saved (C:\Program Files\nodejs\node_modules\npm\lib\utils\npm-registry-client\get.js:136:7)
ERR! error installing yeti@0.1.9pre at Object.cb [as oncomplete] (C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\graceful-fs.js:36:9)
ERR! Error: No compatible version found: connect@'>=1.2.3- <1.3.0-'
ERR! Valid install targets:
ERR! ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.1.0",
"0.2.0","0.2.1","0.2.2","0.2.3","0.2.4","0.2.5","
0.2.6","0.2.7","0.3.0","0.4.0","0.5.0","0.5.1",
"0.5.2","0.5.3","0.5.4","0.5.5","0.5.6","0.5.7","0.5.8","0.
5.9","0.5.10","1.0.0","1.0.1","1.7.2","1.7.3","1.8.0"]
ERR! at installTargetsError (C:\Program Files\nodejs\node_modules\npm\lib\cache.js:424:10)
ERR! at C:\Program Files\nodejs\node_modules\npm\lib\cache.js:406:17
ERR! at saved (C:\Program Files\nodejs\node_modules\npm\lib\utils\npm-registry-client\get.js:136:7)
ERR! at Object.cb [as oncomplete] (C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\graceful-fs.js:36:9)
ERR! Report this *entire* log at:
ERR! <http://github.com/isaacs/npm/issues>
ERR! or email it to:
ERR! <npm-@googlegroups.com>
ERR!
ERR! System Windows_NT 5.1.2600
ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "yeti"
ERR! cwd C:\Documents and Settings\
ERR! node -v v0.6.2
ERR! npm -v 1.0.106

Reid Burke

YUI Developer

  • Username: reid
  • Joined: Mon May 11, 2009 1:02 pm
  • Posts: 28
  • Location: Sunnyvale, California
  • Twitter: reid
  • GitHub: reid
  • Gists: reid
  • IRC: reid
  • YUI Developer
  • Offline
  • Profile

Re: npm install yeti returns error and 'not ok' message

Post Posted: Mon Nov 21, 2011 10:11 am
Hi there!

Could you try: npm install -g yeti instead of installing the Git version?

I will investigate when I get back to my computer; however, I'm currently on vacation so it'll be a bit later. In the meantime, try changing the Connect version in package.json with a newer and available version.

Reid

Gedion W

  • Username: Gedion
  • Joined: Sun Nov 20, 2011 3:42 pm
  • Posts: 2
  • Offline
  • Profile

Re: npm install yeti returns error and 'not ok' message

Post Posted: Tue Nov 22, 2011 4:44 pm
Hi Reid,

Thanks for the quick reply. However I'm still having no luck. Adding the -g flag still returned the same error message as above.

Thank you,

- Gedion

Valentino Aluigi

  • Username: bitlyfied
  • Joined: Wed Nov 30, 2011 7:25 am
  • Posts: 1
  • GitHub: bitlyfied
  • Gists: bitlyfied
  • Offline
  • Profile

Re: npm install yeti returns error and 'not ok' message

Post Posted: Wed Nov 30, 2011 7:32 am
I had a similar issue. A fresh copy of Ubuntu with only installed node.js and npm.
If I do "npm install yeti" or "npm install -g yeti" I get this log:


npm WARN yeti@0.1.8 package.json: bugs['web'] should probably be bugs['url']
npm ERR! error installing yeti@0.1.8 Error: No compatible version found: express@'>=2.2.1- <2.3.0-'
npm ERR! error installing yeti@0.1.8 Valid install targets:
npm ERR! error installing yeti@0.1.8 ["0.14.0","0.14.1","1.0.0beta","1.0.0beta2","1.0.0rc","1.0.0rc2","1.0.0rc3","1.0.0rc4","1.0.0","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","2.5.0","2.5.1"]
npm ERR! error installing yeti@0.1.8 at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! error installing yeti@0.1.8 at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! error installing yeti@0.1.8 at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! error installing yeti@0.1.8 at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9)
npm ERR! Error: No compatible version found: express@'>=2.2.1- <2.3.0-'
npm ERR! Valid install targets:
npm ERR! ["0.14.0","0.14.1","1.0.0beta","1.0.0beta2","1.0.0rc","1.0.0rc2","1.0.0rc3","1.0.0rc4","1.0.0","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","2.5.0","2.5.1"]
npm ERR! at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9)
npm ERR! Report this *entire* log at:
npm ERR! <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR! <npm-@googlegroups.com>
npm ERR!
npm ERR! System Linux 3.0.0-13-generic
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "yeti"
npm ERR! cwd /home/dev/node
npm ERR! node -v v0.6.3
npm ERR! npm -v 1.0.106
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/dev/node/npm-debug.log
npm not ok

Peter-Paul van Gemerden

  • Username: PPvG
  • Joined: Fri Dec 02, 2011 12:34 am
  • Posts: 1
  • Offline
  • Profile

Re: npm install yeti returns error and 'not ok' message

Post Posted: Wed Dec 14, 2011 8:23 am
I'm having the same problem as Valentino.

The error message is very strict on the matter, so I reported the issue on GitHub. Not sure if that will be any help to anyone, but there you go. :-)

Update:

When installing from GitHub (tag v0.1.5), I get: Error: version not found: 1.0.0 : optparse/1.0.0.

After editing package.json -- changing the optparse dependency to version 1.0.1 -- the installation succeeds, but yeti fails to run, throwing the following error: http://pastie.org/3020285.

I'm new to Node, but this looks like an uncaught exception. The version at GitHub tag v0.1.3 fails to install ("Failed to parse package.json data") and while v0.1.0 installs fine, it fails to run as well.

I'm running Node.js v0.6.5 and npm v1.0.106 on Linux (3.1.5-1.fc16.i686).

Dmitry

  • Username: dmitris
  • Joined: Tue Jan 24, 2012 2:13 am
  • Posts: 2
  • GitHub: dmitris
  • Gists: dmitris
  • Offline
  • Profile
Tags:
  • node

Re: npm install yeti returns error and 'not ok' message

Post Posted: Tue Jan 24, 2012 2:22 am
I'm getting an error as well - using node v0.6.8 - complaining it cannot find a suitable express version:

$ npm install -g yeti
npm http GET registry.npmjs.org/yeti
npm http 304 registry.npmjs.org/yeti
npm WARN yeti@0.1.8 package.json: bugs['web'] should probably be bugs['url']
npm http GET registry.npmjs.org/express
npm http GET registry.npmjs.org/connect
npm http GET registry.npmjs.org/jade
npm http GET registry.npmjs.org/nopt
npm http GET registry.npmjs.org/socket.io
npm http 304 registry.npmjs.org/express
npm ERR! error installing yeti@0.1.8

npm ERR! Error: No compatible version found: express@'>=2.2.1- <2.3.0-'
npm ERR! Valid install targets:
npm ERR! ["0.14.0","0.14.1","1.0.0beta","1.0.0beta2","1.0.0rc","1.0.0rc2","1.0.0rc3","1.0.0rc4","1.0.0","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","2.5.0","2.5.1","2.5.2","2.5.3","2.5.4","2.5.5","2.5.6"]
npm ERR! at installTargetsError (/Users/dmitris/.nvm/v0.6.8/lib/node_modules/npm/lib/cache.js:488:10)
npm ERR! at next_ (/Users/dmitris/.nvm/v0.6.8/lib/node_modules/npm/lib/cache.js:438:17)
npm ERR! at next (/Users/dmitris/.nvm/v0.6.8/lib/node_modules/npm/lib/cache.js:415:44)
npm ERR! at /Users/dmitris/.nvm/v0.6.8/lib/node_modules/npm/lib/cache.js:408:5
npm ERR! at Object.saved [as oncomplete] (/Users/dmitris/.nvm/v0.6.8/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR! You may report this log at:
npm ERR! <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR! <npm-@googlegroups.com>
npm ERR!
npm ERR! System Darwin 10.8.0
npm ERR! command "node" "/Users/dmitris/.nvm/v0.6.8/bin/npm" "install" "-g" "yeti"
npm ERR! cwd /Volumes/Virtus/dev/yseclab/trunk
npm ERR! node -v v0.6.8
npm ERR! npm -v 1.1.0-2
npm ERR! message No compatible version found: express@'>=2.2.1- <2.3.0-'
npm ERR! message Valid install targets:
npm ERR! message ["0.14.0","0.14.1","1.0.0beta","1.0.0beta2","1.0.0rc","1.0.0rc2","1.0.0rc3","1.0.0rc4","1.0.0","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","2.5.0","2.5.1","2.5.2","2.5.3","2.5.4","2.5.5","2.5.6"]
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Volumes/Virtus/dev/yseclab/trunk/npm-debug.log
npm not ok


Let me know if you want me to try other versions or something else.

Reid Burke

YUI Developer

  • Username: reid
  • Joined: Mon May 11, 2009 1:02 pm
  • Posts: 28
  • Location: Sunnyvale, California
  • Twitter: reid
  • GitHub: reid
  • Gists: reid
  • IRC: reid
  • YUI Developer
  • Offline
  • Profile

Re: npm install yeti returns error and 'not ok' message

Post Posted: Tue Jan 24, 2012 5:17 pm
Hi folks,

The version of Express depended on by today's published Yeti is not installable on Node.js v0.6.x.

I am focusing my efforts on Yeti Next instead of patching the old Yeti, which is now woefully out-of-date. I'm working hard to ship Yeti Next as soon as it's ready.

As a workaround, you may use nvm or n to switch to Node.js v0.4.x, which would allow for installing and using today's Yeti.

I'm sorry for the trouble. Don't send bugs to the npm project -- this is a problem with Yeti, not Express or npm.

Reid

Dmitry

  • Username: dmitris
  • Joined: Tue Jan 24, 2012 2:13 am
  • Posts: 2
  • GitHub: dmitris
  • Gists: dmitris
  • Offline
  • Profile
Tags:
  • node
  • yeti

Re: npm install yeti returns error and 'not ok' message

Post Posted: Thu Jan 17, 2013 1:37 am
With node v0.8.16, I was able to install yeti (0.2.15):
Code:
$npm install -g yeti
[...]
Thanks for installing Yeti 0.2.15

Recent changes in HISTORY.md:

## 0.2.15 / 2013-01-10

  * Fix #121, ensure socket is truthy during browser setup.
  * Fix #122, entity encode failure messages in XML.
  * WebDriver browser launching support.
  * Add iPad and PhantomJS as recognized browsers.
  [ 8 posts ]
New Topic | Post Reply | Print view
Previous topic | Next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum