Forums

Posting in these forums is disabled. These forums will be available for archive purposes. Please join the new forums at the links below:

  • yui-support - replaces the `YUI 3.x` and `YUI 3 Gallery` forums.
    We have created the following discussion categories within this group to aid discoverability for these most-used topics:
    • Charts for YUI Charts support.
    • DataTable for YUI DataTable support.
    • Gallery for YUI Gallery support, including support for published Gallery components as well as the Gallery process in general.
    • Tools for support of YUI’s suite of developer tools such as selleck, shifter, grover, yogi, etc.
    • Everything Else for questions that don’t fit one of the categories above, we’ve got you covered here.
  • yui-deprecated - replaces the `YUI 2.x` forum and the forums of other deprecated products (`YUI Doc`, `Builder`, `YUI PHP Loader`, etc.).
  [ 3 posts ]
New Topic | Post Reply | Print view
Previous topic | Next topic

Alexei White

  • Username: alexeiwhite
  • Joined: Thu May 02, 2013 9:29 am
  • Posts: 2
  • GitHub: alexsaves
  • Gists: alexsaves
  • Offline
  • Profile
Tags:
  • yeti
  • configuration
  • windows

Yeti wont run on Windows

Post Posted: Thu May 02, 2013 9:32 am
I installed Yeti using the npm. Every time I run it. it just says:
C:\projects\portal_test_harness\portaltest\portaltest\client\js\unittests\unit>yeti --server
? Whoops! TypeError: Arguments to path.join must be strings
at f (path.js:204:15)
at Object.filter (native)
at Object.exports.join (path.js:209:40)
at Configuration.configurationFinder [as locate] (C:\Users\alexei.white\AppData\Roaming\npm\node_modules\yeti\lib\cli\configuration.js:52:40)
at Configuration.proto.importFromDirectory (C:\Users\alexei.white\AppData\Roaming\npm\node_modules\yeti\lib\cli\configuration.js:184:37)
at Configuration.proto.home (C:\Users\alexei.white\AppData\Roaming\npm\node_modules\yeti\lib\cli\configuration.js:219:10)
at CLI.route (C:\Users\alexei.white\AppData\Roaming\npm\node_modules\yeti\lib\cli\index.js:616:34)
at Object.<anonymous> (C:\Users\alexei.white\AppData\Roaming\npm\node_modules\yeti\cli.js:16:10)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)

If you believe this is a bug in Yeti, please report it.
http://yuilibrary.com/projects/yeti/report
Yeti v0.2.21
Node.js v0.10.4

Mido Basim

  • Offline
  • Profile

Re: Yeti wont run on Windows

Post Posted: Sat May 18, 2013 4:43 am
Hi Alexei,

I had the same issue. It is related to the command line tool in Windows.
I used http://msysgit.github.io/ instead and it worked fine with that :).

voila

  • Username: voila
  • Joined: Mon Jul 01, 2013 2:53 am
  • Posts: 4
  • GitHub: 0xvoila
  • Gists: 0xvoila
  • IRC: voila
  • Offline
  • Profile

Re: Yeti wont run on Windows

Post Posted: Mon Jul 01, 2013 3:17 am
set HOME=<path to your home directory>like c:\users\voila .

then it should work.

Just for information : yeti have some issues with windows :)
  [ 3 posts ]
New Topic | Post Reply | Print view
Previous topic | Next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum