Forums

Posting in these forums is disabled. These forums will be available for archive purposes. Please join the new forums at the links below:

  • yui-support - replaces the `YUI 3.x` and `YUI 3 Gallery` forums.
    We have created the following discussion categories within this group to aid discoverability for these most-used topics:
    • Charts for YUI Charts support.
    • DataTable for YUI DataTable support.
    • Gallery for YUI Gallery support, including support for published Gallery components as well as the Gallery process in general.
    • Tools for support of YUI’s suite of developer tools such as selleck, shifter, grover, yogi, etc.
    • Everything Else for questions that don’t fit one of the categories above, we’ve got you covered here.
  • yui-deprecated - replaces the `YUI 2.x` forum and the forums of other deprecated products (`YUI Doc`, `Builder`, `YUI PHP Loader`, etc.).
  [ 4 posts ]
New Topic | Post Reply | Print view
Previous topic | Next topic

Nick Stonebraker

  • Username: NStone79
  • Joined: Tue Jan 22, 2013 1:36 pm
  • Posts: 3
  • Offline
  • Profile
Tags:
  • ENETUNREACH
  • EADDRINUSE
  • test dependencies
  • resolving paths

Path resolution and dependency issues

Post Posted: Tue Jan 22, 2013 2:02 pm
What am I doing wrong here?

1) start the yeti hub from the yui directory
c:\project\src\main\webapp\resources\yui> yeti -s

2) connect a browser

3) launch yeti from my modules folder where the tests are located...
c:\project\src\main\webapp\resources\modules\mymodule> yeti mymodule-test.html


When i start the hub it attempts to connect to the local machine on port 8080 and I get a message: Unable to connect to Hub at http://<machineName>:8080/ with Error: connect ENETUNREACH. After that I starts a new hub on port 9000

When I run yeti in my modules directory it does the same unsuccessful attempt to connect to the local machine on port 8080 and then I get an error message: ? Whoops! Error: listen EADDRINUSE

Lastly... presuming I had yeti running. How is it going to handle my non-YUI test dependencies with are in a different folder than where the hub was run from and where the test is located?

Alexei White

  • Username: alexeiwhite
  • Joined: Thu May 02, 2013 9:29 am
  • Posts: 2
  • GitHub: alexsaves
  • Gists: alexsaves
  • Offline
  • Profile

Re: Path resolution and dependency issues

Post Posted: Thu May 02, 2013 9:54 am
Yah I'm starting to get the sense that Yeti is still a bit immature for production use. We're finding it to be very finicky.

voila

  • Username: voila
  • Joined: Mon Jul 01, 2013 2:53 am
  • Posts: 4
  • GitHub: 0xvoila
  • Gists: 0xvoila
  • IRC: voila
  • Offline
  • Profile
Tags:
  • yeti

Re: Path resolution and dependency issues

Post Posted: Mon Jul 01, 2013 3:09 am
hello Nick,
Can you please tell me on which OS you are running yeti.
If it is Windows then yup there are huge problem for you because yeti is not well tested for windows users.
Yes, If it is ubuntu then we can look into it.

voila

  • Username: voila
  • Joined: Mon Jul 01, 2013 2:53 am
  • Posts: 4
  • GitHub: 0xvoila
  • Gists: 0xvoila
  • IRC: voila
  • Offline
  • Profile

Re: Path resolution and dependency issues

Post Posted: Mon Jul 01, 2013 3:11 am
Hello Alexei,
Well yeti has issues with windows not it is really good on ubuntu :)
  [ 4 posts ]
New Topic | Post Reply | Print view
Previous topic | Next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum