Ticket #2528133 (closed defect)

Reporter


Yavor Atanasov
Opened: 12/5/11
Last modified: 12/12/12
Status: closed
Type: defect
Resolution: wontfix

Owner


Satyen Desai
Target Release:
Priority:
Summary: YUI Compressor built wrongly in the Maven Central repository
Description:

We are currently trying to update our version of the yuicompressor from 2.3.6 to 2.4.6 (or any 2.4.* version) via Maven using the Maven Cetral repo:
http://search.maven.org/#browse%7C318267230

We see that in the 2.4.* versions you have taken out the previously embedded Rhino and it is now specified as a dependency. This is fine, but we are seeing an error caused by the manifest file not
specifying a main class. The problem is described in this thread:
http://yuilibrary.com/forum/viewtopic.php?f=94&t=5400

The executable should be rebuilt using the following guidelines:
http://maven.apache.org/shared/maven-archiver/examples/classpath.html#aMake

Type: defect Observed in Version: 2.4.6
Component: YUICompressor Severity: S3 (normal)
Assigned To: Satyen Desai Target Release:
Location: Priority:
Tags: Relates To:
Browsers: N/A
URL: http://search.maven.org/#browse%7C318267230
Test Information:

Change History

Jenny Donnelly

YUI Developer

Posted: 12/12/12
  • resolution changed to wontfix
  • status changed from new to closed

Thank you for your bug report. We are deprecating YUI Compressor in favor of yuglify. Please see our announcement for more information: http://www.yuiblog.com/blog/2012/10/16/state-of-yui-compressor/. We will consider migrating these legacy tickets to GitHub if there are community maintainers willing to step up and own them.