Ticket #2528263 (closed defect)

Reporter


carlos
Opened: 07/29/09
Last modified: 07/31/09
Status: closed
Type: defect
Resolution: duplicate
Duplicate of: #2527764

Owner


Luke Smith
Target Release: 2.8.0
Priority: P3 (normal)
Summary: Certain style sheets break YUI Stylesheet utility
Description:

Certain combinations of CSS declarations break the Stylesheet utility. The style sheet from the test case is:

--- start ---
.someclass
{

display: block;
}

.someclass, .someother
{

height: 20px;
}

.notatfirst
{ display: none;
}

--- end ---

To reproduce the problem in Javascript, look at this line from the testcase below:

var sheet = YAHOO.util.StyleSheet(YAHOO.util.Dom.get('commonsheet'));

It produces an Object expected stylesheet-debug.js, line 195 character 17 in IE8. Problem happens with IE6 and IE8 (IE7 untested). The sample URL works well with Opera 9 anf Firefox 3.5 (always
on Windows).

If I remove the ", .someother" from the style sheet (i.e. having two style declarations for the same class), then both Opera and Firefox break too.

Type: defect Observed in Version: 2.7.0
Component: StyleSheet Severity: S3 (normal)
Assigned To: Luke Smith Target Release: 2.8.0
Location: Library Code Priority: P3 (normal)
Tags: Relates To:
Browsers: IE 6.x,IE 8.x
URL: http://astronomia.org/yuibug.html
Test Information:

The URL given is the testcase: http://astronomia.org/yuibug.html

The page should display a list-item with the text This should be visible. The Javascript just adds a display: 'list-item' where a display: none previously applied.

Change History

Luke Smith

YUI Contributor

Posted: 07/30/09
  • location changed to Library Code
  • milestone changed to 2.8.0
  • priority changed to P3 (normal)
  • status changed from new to accepted

Luke Smith

YUI Contributor

Posted: 07/31/09
  • duplicate changed to #2527764
  • resolution changed to duplicate
  • status changed from accepted to closed

This ticket was marked as a duplicate of ##2527764

Luke Smith

YUI Contributor

Posted: 07/31/09
  • resolution changed from duplicate
  • status changed from closed to reopened

Luke Smith

YUI Contributor

Posted: 07/31/09
  • duplicate changed from 0 to 2527764
  • resolution changed to duplicate
  • status changed from reopened to closed

This ticket was marked as a duplicate of #2527764