Ticket #1946011 (closed defect)

Reporter


sfbugs
Opened: 04/18/08
Last modified: 04/18/08
Status: closed
Type: defect
Resolution: Wont Fix

Owner


Todd Kloots
Target Release:
Priority: P3 (normal)
Summary: Flash shows through FireFox on Mac OS X
Description:

I have a dev site up right now where Flash shows over the menu. It works in Windows IE and Windows Firefox, but now OS X Firefox.

for an example:
http://www.bowl365.com

john@bowlingball.com

Type: defect Observed in Version: None
Component: Menu Severity: S3 (normal)
Assigned To: Todd Kloots Target Release:
Location: Priority: P3 (normal)
Tags: Relates To:
Browsers:
URL:
Test Information:

Change History

George

YUI Developer

Posted: 04/21/08
  • summary changed from Flash shows through FireFox on Mac OS X to [#1886321] Flash shows through FireFox on Mac OS X

This bug report is being forwarded to the author or current owner of the affected component for additional investigation and response.

Todd Kloots

YUI Contributor

Posted: 04/21/08
  • status changed from assigned to closed

John -

This is actually due to a bug in FF for Mac. The root of the problem is the alpha transparency of the Menu's shadow. This bug is fixed in FF 3, but sadly there isn't anything that we can do to fix this problem with FF 2. The workaround is simply to turn off the shadow for Mac FF when you are positioning submenus over Flash content. Here is a an example:

http://yuiblog.com/sandbox/yui/v251/examples/menu/example01.html

Regards,
Todd

Todd Kloots

YUI Contributor

Posted: 04/21/08

File Added: firefox-flash-opacity-bug-demo.html

  • Username:
Posted: 08/29/08

This bug is also applicable to Firefox 2 Linux and Firefox 2 Linux, the menu goes under the Flash.

Any solution for Linux users ?

Todd Kloots

YUI Contributor

Posted: 08/29/08

Firefox on Linux isn't one of the currently supported OS + Browser combinations for YUI: http://developer.yahoo.com/yui/articles/gbs/

You can try turning off the shadow as I suggested in my previous comment.

- Todd

  • Username:
Posted: 08/29/08

Thanks for your quite response.

It does not work even with the shadow turned off.
This apply to Linux FF2, FF3 and Konqueror.

sfbugs

Posted: 01/7/09

This ticket was imported from Source Forge.

Orginially submitted by: nobody